Browser support

The following is a list of browsers that are compatible with ENTSO-E tools.


entsoe.eu

The ENTSO-E website supports the latest versions of the following browsers. Internet Explorer versions 10 and below are not supported on entsoe.eu.

  • Chrome
  • Firefox
  • Safari
  • Internet Explorer 11+
  • Edge
GET THE MOST POWERFUL NEWSLETTER IN BRUSSELS